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About this exam 
Exam questions subject to change 

This exam is designed to test the candidate’s knowledge and skills in fundamentals and best 

practices for building, deploying and maintaining applications a web site with Kentico CMS 

5 to deliver dynamic web site content. 

 Questions that contain code will be presented in C#.  

 Exam covers all release of Kentico CMS 5. 

Purchase a voucher: http://www.kentico.com/Training/Certification.aspx  

Candidate Profile 
The candidate works in a development environment that uses Kentico CMS 5 and the .NET 

Framework to create and deliver dynamic web application. The candidate should have at 

least one year of experience developing applications using Kentico CMS, or attended a 

certified Kentico CMS 5 Developer training. 

In addition, the candidate should be able to demonstrate the following: 

 A solid understanding of the .NET Framework and ASP.NET development 

 Experience in creating data driven web user interfaces 

 Experience in creating layouts using Cascading Style Sheets 

 Experience with setup and deployment of a web site 

Skills Measured  
The exam measures your ability to accomplish the technical tasks listed below. 

 Describe the key features of Kentico CMS 5 

 Describe the architecture of Kentico CMS 5 

 Setup a Kentico CMS Development Environment 

 Navigate the CMS Desk and Site Manager to perform common administration 

functions 

 Describe document types and how they are used within Kentico CMS 

 Create custom document types 

 Describe the process used for developing a Kentico CMS site 

 Understand page development options using Kentico CMS 

http://www.kentico.com/Training/Certification.aspx
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 Create page templates using both the Portal Engine and ASPX templates 

 Create and manage CSS Style sheets using Kentico CMS 

 Create and implement Web Parts 

 Describe the common Kentico CMS Web Parts 

 Create complex transformations  

 Access and manipulate data stored within the Kentico CMS content repository 

 Secure the Kentico CMS Web site using variety of technologies, including 

authentication and membership 

 Implement and manage workflow and versioning using Kentico CMS  

 Setup and implement a multi-lingual sites 

 Add additional functionality using the Kentico API 

 Describe additional functionality using Kentico CMS extensibility 

 View runtime and caching information using the built-in Kentico CMS functionality 

 Deploy a Kentico CMS website 
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Exam Preparation Questions 
 

1. In which of the following areas can custom functions not be used? (mark any 

incorrect choice) 

a. Menu Captions 

b. Transformations 

c. Code behind 

d. Forum Posts 

Answer A, D 
 

2. The creation of transformations is NOT allowed in which of the following CMS 5 

administration interfaces? (mark all that are incorrect) 

a. CMS Site Manager ->Development -> Custom Tables 

b. CMS Site Manager ->Development -> Document Types 

c. CMS Desk -> Tools ->Custom Tables 

d. CMS Desk -> Content tree -> Properties ->Web Part Properties 

Answer C, D 
 

3. (True/False) The Design tab in CMS Desk is only available with Page Templates built 

with the ASPX model 

a. True 

b. False 

Answer B 
 

4. (True/False) In order to debug a page template with Visual Studio the debug key is 

added to the web.config file 

a. True 

b. False 

Answer B 
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5. The CMS.CMSHelper.CMSContext class provides information about which of the 

following? 

a. Current site 

b. Current user 

c. Current page 

d. All of the above 

Answer D 
 

6. Which of the following API class allows the viewing of user information? (mark all 

that are correct) 

a. CMS.SettingsProvider.CMSConstraints 

b. CMS.Community.FriendInfo 

c. CMS.SiteProvider.UserInfoProvider 

d. CMS.CMSHelper.CMSContext 

Answer C, D 
 

7. When displaying dynamic data in a transformation, which of the following are NOT 

valid (mark all that are NOT correct) 

a. Eval(“”), API, Built in Methods 

b. HTML Markup, Eval(“”), Built in Methods 

c. Custom Function, HTML Markup, User Control 

d. Dynamic Data cannot be displayed 

Answer D 
 

8. (True/False) Transformations are applied to the Editable Region control type using 

the Design tab. 

a. True 

b. False 

Answer B 
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9. Entering the /products/% into the Path property of a web part will select which 

documents 

a. All product type documents under the root path 

b. All news type documents under the products path 

c. All documents under the products path 

d. All document starting at the root 

Answer C 
 

10. (True/False) the CMS.CMSHelper.TreeHelper.SelectNodes method returns a 

DataSet object containing the nodes (documents) from a given path. 

a. True 

b. False 

Answer A 
 

11. Transformations cannot be applied to a portal engine page from these areas? (mark 

all that apply) 

a. CMS Desk -> Choose page -> Design tab -> Web part properties 

b. CMS Desk -> Choose document -> Design tab -> Web part properties 

c. CMS Desk -> Choose Page -> Properties -> Web part properties 

d. CMS Desk -> Choose page -> Page tab -> Web part properties 

Answer C, D 
 

12. (True/False) Transformations can be edited in the Kentico CMS 5 interface through 

the CMS Site Manager -> Development -> Document Types 

a. True 

b. False 

Answer A 
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13. (True/False) Transformations can be edited in the Kentico CMS 5 interface through 

the CMS Desk -> Tools -> Custom Tables 

a. True 

b. False 

Answer B 

  
14. Which of the following will cause an error when referencing a transformation? 

(Mark all that will generate an error) 

a. En-us.MyTransformation 

b. ClassName.MyTransformation 

c. DocumentName.MyTransformation 

d. Sitename.MyTransformation 

Answer A, C, D 
 

15. (True/False) In order to enable workflow, versioning and content/locking site wide 

you must at least enable Check in/Check Out in Site Administrator Content 

Management Settings and define a scope for the default workflow 

a. True 

b. False 

Answer A 
 

16. (True/False) In Kentico CMS 5 you are able to define a maximum of two document 

aliases for any document. 

a. True 

b. False 

Answer B 
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17. (True/False) All widgets are based on web parts 

a. True 

b. False 

Answer A 
 

18. (True/False) By default when a new widget is created all configuration properties 

are automatically exposed 

a. True 

b. False 

Answer B 
 

19. Workflow includes which of the following features (Select all that are correct) 

a. Organize the process of content creation 

b. Versioning 

c. Content locking (Check in/Check out) 

d. Document archiving 

Answer A, B, C, D 
 

20. Document types have which of the following? 

a. Editing form layout 

b. Data structures 

c. Transformations 

d. All of the above 

Answer D 
 

21. Creating custom document types is done in which interface? 

a. CMS Desk 

b. Content tree 

c. Design tab 

d. Site Manager 

Answer D 
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22. (True/False) All workflow settings are managed in Site Manager -> Development -> 

Workflows 

a. True 

b. False 

Answer B 
 

23. Kentico CMS 5 content staging support which of the following (select all that apply) 

a. Document attachments 

b. Document relationships 

c. Custom tables 

d. ACLs (document permissions) 

Answer A, B, C 
 

24. (True/False) Kentico CMS 5 Content Staging will automatically synchronize Blog 

comments 

a. True 

b. False 

Answer B 
 

25. (True/False) The TreeNode methods are used to access both un-versioned and 

versioned document in the CMS system 

a. True 

b. False 

Answer B 
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26. In Kentico CMS 5 ASPX Page Templates provide the following features? (Select all 

that correct) 

a. Design tab 

b. Preview mode 

c. Editing mode 

d. Master page tab 

Answer B, C 
 

27. Which Using statement is needed to access a node in the Content tree? 

a. Using CMS.SiteProvider; 

b. Using CMS.GlobalHelper; 

c. Using CMS.TreeEngine; 

d. Using CMS.DataEngine; 

Answer C 
 

28. Kentico CMS 5.5 natively supports which of the following authentication methods? 

a. Open ID 

b. Windows Live ID 

c. Active Directory 

d. All of the above 

Answer D 
 

29. Which is not an available page template type for Kentico CMS 5? (Mark all that are 

incorrect) 

a. Portal Page 

b. ASPX Page 

c. JSP Page 

d. Master Page 

Answer C, D 
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30. Which DLL do you set a reference to in order to add the Kentico CMS controls in 

Visual Studio? 

a. Kentico.WebControls.dll 

b. CMS.UIControls.dll 

c. CMS.Controls.dll 

d. Kentico.Controls.dll 

Answer C 
 

31. True/False – Custom document types are searchable using smart search 

a. True 

b. False 

Answer A 
 

32. True/False – In Kentico CMS 5 it is not possible to restrict document types by site 

a. True 

b. False 

Answer B 
 

33. True/False – Namespaces are used to group custom document types together.  

a. True 

b. False 

Answer A 
 

34. What types of custom fields can you create with a custom document type? 

a. Text box 

b. Media selection 

c. Label 

d. All of the above 

Answer D 
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35. True/False – New document types must contain at least one custom field 

a. True 

b. False 

Answer B 
 

36. Which of the following Using statements in needed to access the current user’s 

email address? 

a. Using CMS.DataEngine; 

b. Using CMS.GlobalHelper; 

c. Using CMS.TreeEngine; 

d. Using CMS.SiteProvider; 

Answer D 
 

37. Which action allows a custom module to be visible in Site Manager? 

a. Add a special Site Manager permission to the custom module and allow 

access CMS Desk administrators 

b. Add a UI element to the My Desk module 

c. Copy the ASPX file to the ~/CMSSiteManager directory 

d. Check the “Show in development” box on the General tab for the custom 

module 

Answer D 
 

38. Which web.config key is used to enable custom event handlers in your Kentico CMS 

5 website? 

a. <add key = “CMSUseCustomHandlers” value=true> 

b. <add key = “CMSUseSessionCookies”  value=”true> 

c. <add key = “CMSUseDefinedEventHandlers” value=”true”> 

d. <add key = “CMSUseSessionCookies” value=”true”> 

Answer A 
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39. True/False – Edit/Published/Archived are the default steps created for any new 

workflow 

a. True 

b. False 

Answer A 
 

40. When writing a Global Event handler for updating documents without a workflow 

which class would you place your code in? 

a. CustomDataHandler.cs 

b. CustomTreeNodeHandler.cs 

c. CustomWorkflowHandler.cs 

d. CustomSecurityHandler.cs 

Answer B 
 

41. When writing a Global Event handler for updating documents that are part of a 

workflow which class would you place your code in? 

a. CustomDataHandler.cs 

b. CustomTreeNodeHandler.cs 

c. CustomWorkflowHandler.cs 

d. CustomSecurityHandler.cs 

Answer C 
 

42. True/False – The CustomExceptionHandler is a Global event that could be used to 

send an email to the administrator if an error occurs.  

a. True 

b. False 

Answer A 
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43. True/False – The following code snippet will create a new user that has access to 

CMS Desk and Site Manager 

// Create UserInfo 

UserInfo user = new UserInfo(); 

// Set properties 

user.UserName = "Alice"; 

user.FirstName = "Alice"; 

user.LastName = "Cooper"; 

user.FullName = "Alice Cooper"; 

user.Email = "alice.cooper@domain.com"; 

user.IsEditor = true; 

user.PreferredCultureCode = "en-us"; 

user.Enabled = true; 

// Create new user 

CMS.SiteProvider.UserInfoProvider.SetUserInfo(user); 

a. True 

b. False 

Answer B 
 

44. Which of the following features are available when using a custom document type? 

(Select all that are correct) 

a. Have alternative forms 

b. Have transformations 

c. Have page templates 

d. Have custom fields 

Answer A, B, C, D 
 

 


